Настроим Cisco
быстро и просто

Etherchannel на коммутаторах Cisco

Февраль 26, 2016

Read the article CONFIGURING ETHERCHANNELS (LINK AGGREGATION) ON CISCO SWITCHES in Read in EnglishEnglish

Технология etherchannel (или port channel) позволяет из нескольких портов коммутатора (от 2 до 8) сделать один логический.
Эта технология используется для увеличения надежности соединения – трафик идет сразу по всем активным портам, а выход из строя любого физического порта никак не влияет на доступность всего соединения. Естественно, при использовании также увеличивается и скорость соединения

Важно!
Важно помнить, что подобные соединения возможно настроить только на портах с одинаковой пропускной способностью. Например на двух портах Fastethernet (100 + 100 Мбит/сек) или двух Gigabitethernet (1 + 1 Гбит/сек).
Нельзя объединить в один etherchannel интерфейсы Fastethernet (100Mb/s) и Gigabitethernet (1 Гбит/сек).

Важно!
Настройки etherchannel должны быть идентичными на обоих устройствах, которые соединяются подобным образом, будь то два коммутатора или коммутатор и сервер.

deltaconfig - cisco аутсорсинг

Для примера приведу настройки для соединения двух коммутаторов Cisco. Пусть это будут Cisco Catalyst 3560, хотя технология и синтаксис команды практически неизменен на всех моделях.
Настройка Etherchannel или агрегация подключений

На первом коммутаторе SW-DELTACONFIG-1 необходимо создать логический интерфейс port-channel с уникальным порядковым номером (например 1)

SW-DELTACONFIG-1(config)#
interface port-channel1

Далее привязать к нему нужное количество физических портов. Не забудьте включить их командой no shut

SW-DELTACONFIG-1(config)#
interface Gi 0/1
channel-group 1 mode active
no shut
 
interface Gi 0/2
channel-group 1 mode active
no shut

В конфигурации логического интерфейса добавить все необходимые настройки: описание, настройки trunk или access, разрешенные к передаче Vlan и др.

SW-DELTACONFIG-1(config)#
interface port-channel1
description ---Link to SW-DELTACONFIG-2---
switchport mode trunk
switchport trunk allowed vlan 1-10,20-30
no shut

Все выполненные команды автоматически будут добавлены в конфигурацию физических интерфейсов, привязанных к данному port-channel. Проверить это можно командой sh run interface «название интерфейса». Чтобы сделать это напрямую из режима конфигурирования используйте do перед командой

SW-DELTACONFIG-1(config)# do sh run interface Gi 0/1
interface GigabitEthernet0/1
description ---Link to SW-DELTACONFIG-2---
switchport mode trunk
switchport trunk allowed vlan 1-10,20-30
channel-group 1 mode active

Важно!
Я настоятельно рекомендую создавать подобные интерфейсы portchannel именно в такой последовательности:
— сначала сам логический интерфейс
— затем привязать его к физическим портам
— и уже после этого производить настройки логического интерфейса. Вся конфигурация переносится на физические порты автоматически.
Подобная последовательность исключит возможность ошибки в настройке, так как малейшее расхождение параметров ведет к некорректной работе всего portchannel.

Важно!
После включения физического интерфейса в логический на нем нельзя выполнять настройки. Любые изменения конфигурации производятся только(!) на логическом интерфейсе port-channel. Любое изменение на физическом порту коммутатора, включенного в port-channel ведет к выходу из строя всего агрегированного соединения.

На втором коммутаторе SW-DELTACONFIG-2 все настраивается аналогично. В примере оба коммутатора одинаковой модели Cisco Catalyst 3560 с идентичным набором интерфейсов. Поэтому отличия можно заметить только в поле description.

SW-DELTACONFIG-2(config)#
interface Gi 0/1
channel-group 1 mode active
no shut
 
interface Gi 0/2
channel-group 1 mode active
no shut
 
interface port-channel1
description ---Link to SW-DELTACONFIG-1---
switchport mode trunk
switchport trunk allowed vlan 1-10,20-30
no shut

Проверка настроек

Помимо того, что стоит убедиться в наличии всех нужных строк в конфигурациях коммутаторов командой sh run, для проверки работы etherchannel используйте команду show etherchannel summary.


SW-DELTACONFIG-1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
 
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
 
Number of channel-groups in use: 1
Number of aggregators: 1
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Gi0/1(P) Gi0/2(P)

Буквы P рядом с именами физических портов Gi 0/1 и Gi 0/2 означают, что интерфейсы функционируют исправно и входят в логическое подключение Portchannel 1. Символ D рядом с именем интерфейса будет означать, что интерфейс неактивен. Вероятнее всего стоить проверить соединение проводов и все настройки.

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
SWR-DELTACONFIG-1#write
Building configuration...
[OK]

Перейти к оглавлению

 

avatar
×

Форма для связи